DevHeads.net

Postings by Antonio Trande

Updating/rebuilding of coin-or packages

Hi all.

Updates of coin-or-Sample/CoinUtils/Ipopt packages are coming on
Rawhide; involved packages:

$ dnf repoquery --release rawhide --enablerepo=*-source
--disablerepo=rpmfusion* --disablerepo=*modular* --whatrequires
coin-or-CoinUtils-devel
Last metadata expiration check: 0:00:02 ago on lun 08 apr 2019 18:31:27
CEST.
coin-or-Alps-0:1.5.5-9.fc30.src
coin-or-Alps-devel-0:1.5.5-9.fc30.i686
coin-or-Alps-devel-0:1.5.5-9.fc30.x86_64
coin-or-Bcp-0:1.4.3-9.fc30.src
coin-or-Bcp-devel-0:1.4.3-9.fc30.i686
coin-or-Bcp-devel-0:1.4.3-9.fc30.x86_64
coin-or-Bcps-0:0.94.4-9.fc30.src
coin-or-Bcps-devel-0:

Could not execute import_srpm

Hi all.

I can't upload source archive of new package 'smoldyn'

$ fedpkg import ../../smoldyn-2.58-1.fc29.src.rpm
Uploading: /home/sagitter/rpmbuild/SRPMS/fedora-scm/smoldyn/smoldyn-2.58.tgz
########################################################################
100.0%
Could not execute import_srpm: Fail to upload files. Server returns
status 408

Call for maintainers of Scotch package (bz#1680315)

Hello.

Please, take a look to this issue
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1680315" title="https://bugzilla.redhat.com/show_bug.cgi?id=1680315">https://bugzilla.redhat.com/show_bug.cgi?id=1680315</a>

dcmtk upgrade on rawhide

Hi all.

I prepared a dcmtk-3.6.4 rpm for upgrading this package on f30/rawhide.
Its dependencies are:

$ dnf repoquery --release rawhide --enablerepo=*-source
--disablerepo=rpmfusion* --disablerepo=*modular* --whatrequires dcmtk-devel
Last metadata expiration check: 3:27:58 ago on sab 02 mar 2019 12:40:33 CET.
OpenImageIO-0:2.0.5-1.fc30.src
aeskulap-0:0.2.2-0.37.beta2.fc30.src
ctk-0:0.1-0.10.20171224git71799c2.fc29.src
gtatool-0:2.2.0-11.fc28.src
orthanc-0:1.5.4-1.fc30.src
vxl-0:1.17.0-29.fc30.src

dcmtk and related deps have been rebuilt on a dedicated Copr space:
<a href="https://copr.fedorainfraclo" title="https://copr.fedorainfraclo">https://copr.fedorainfraclo</a>

Orphaning procedure for qblade

Hi all.

I abandoned qblade packaging because upstream is unresponsive (as always).
Currently, qblade does not compile with gcc9.

Upstream project: <a href="https://sourceforge.net/projects/qblade/" title="https://sourceforge.net/projects/qblade/">https://sourceforge.net/projects/qblade/</a>

Call for libtimidity owners

Hello!

Please, take a look to

<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1630466" title="https://bugzilla.redhat.com/show_bug.cgi?id=1630466">https://bugzilla.redhat.com/show_bug.cgi?id=1630466</a>
<a href="https://src.fedoraproject.org/rpms/libtimidity/pull-requests" title="https://src.fedoraproject.org/rpms/libtimidity/pull-requests">https://src.fedoraproject.org/rpms/libtimidity/pull-requests</a>

HDF4 update to the release 4.2.14

Hi all.

I'm going to update HDF to the release 4.2.14 on f29+.
If your need to test it before, this is the scratch build just done on
fc30: <a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=30641568" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=30641568">https://koji.fedoraproject.org/koji/taskinfo?taskID=30641568</a>

IBM buying RedHat

"IBM to acquire Red Hat in deal valued at $34 billion"

<a href="https://www.cnbc.com/2018/10/28/ibm-is-reportedly-nearing-deal-to-acquire-red-hat.html" title="https://www.cnbc.com/2018/10/28/ibm-is-reportedly-nearing-deal-to-acquire-red-hat.html">https://www.cnbc.com/2018/10/28/ibm-is-reportedly-nearing-deal-to-acquir...</a>

RHBZ#1639646 [OpenMPI issue]

Hello everyone.

In reference to the bug
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1639646" title="https://bugzilla.redhat.com/show_bug.cgi?id=1639646">https://bugzilla.redhat.com/show_bug.cgi?id=1639646</a>, is anyone else ran
into this problem with OpenMPI recently?

Orphaning procedure for mozilla-requestpolicy rpm

Hi all.

I'm orphaning 'mozilla-requestpolicy' package.
Feel free to adopt it.

Best regards.

python2-future on fedora 30+

Hi all.

Are we ready for excluding python2-future on fedora 30+ ?

$ dnf repoquery --release rawhide --enablerepo=*-source
--disablerepo=rpmfusion* --whatrequires python2-future

Last metadata expiration check: 0:00:00 ago on ven 21 set 2018 14:41:49
CEST.

buildbot-0:1.3.0-1.fc29.src
buildbot-master-0:1.3.0-1.fc29.noarch
buildbot-worker-0:1.3.0-1.fc29.noarch
certbot-0:0.27.1-1.fc30.src
crda-0:3.18_2018.05.31-5.fc29.src
httpwatcher-0:0.5.1-3.fc29.src
mozilla-requestpolicy-0:1.0-0.22.20171019git633302.fc29.src
preprocess-0:1.2.3-0.6.20170318git6e868b.fc29.src
python-CommonMark-0:0.7.5-3.fc29.s

Retiring procedure for nini and smuxi packages

Hi all.

I'm going to retire the packages 'nini' and 'smuxi' on rawhide within
24h since now. Both upstream project look like over.

Scons python2 on fedora 30+

Hello!

Regarding Python2 package removal, 'python2-SCons' needs special
attention, i guess.
It's required for building by many packages on current 'rawhide':

$ dnf repoquery --release rawhide --enablerepo=*-source
--disablerepo=rpmfusion* --whatrequires scons

boswars-0:2.7-15.svn160110.fc28.src
btanks-0:0.9.8083-16.fc27.src
camotics-0:1.1.1-13.fc29.src
compat-tolua++-0:1.0.93-9.fc29.src
csstidy-0:1.4-20.fc29.src
elfelli-0:0.3.1-19.fc27.src
endless-sky-0:0.9.8-6.fc29.src
godot-0:3.0.4-2.fc29.src
gpick-0:0.2.6-0.rc1.fc28.1.src
gpsd-0:3.17-5.fc29.src
lcdtest-0:1.18-20.fc29.src
libnxt-0:0.3-19.

Dropping python2 Biopython on fedora 30+

Hello everyone.

Python2 Biopython is required by 'python-MDAnalysis' on fedora 30+
(other than 'openms', already modified).

Ask to the maintainer of 'python-MDAnalysis' (Dominik Mierzejewski -
rathann) if we are ready for switching to Python3 definitively.

Best regards.

Orphaning procedure for python-assimulo

Hello everyone.

I'm leaving the maintenance of 'python-assimulo' package; if someone
wishes take care of it, please reply here.

Regards.

Orphaning procedure for python-ivi -vxi11 -usbtmc -testify

Hello everyone.

I'm orphaning following Python packages on Fedora (and EPEL):

python-ivi
python-vxi11
python-usbtmc
python-testify

I will retire them within 3 weeks if none is interested to maintain any
or all of them.

Regards.

libsbw soname bump

Hi all.

'libsbw' soname will change from 2.11 to 2.12
Just 'COPASI' will need a rebuild, probably.

Regards.

Python 3.6.5 still used on rawhide

Hi all.

I'm confused...

Why recent python-biopython rebuild is still using Python 3.6.5 on rawhide?

SuperLU update

Hello everyone.

SuperLU update to 5.2.1 release is expected within next days (7 at
least) on rawhide; dependent packages shouldn't have problems when
rebuilt against SuperLU-5.2.1.

Please, test your own software before and point out potential issue.

Rebuilds tested on Copr:
<a href="http://copr-fe.cloud.fedoraproject.org/coprs/sagitter/ForTesting/builds/" title="http://copr-fe.cloud.fedoraproject.org/coprs/sagitter/ForTesting/builds/">http://copr-fe.cloud.fedoraproject.org/coprs/sagitter/ForTesting/builds/</a>

Regards.

SSE2 support on PPC/s390/ARM

Hello everyone.

'blake2' code inside 'Openclonk-8.1' source code requires SSE2 support
that seems unavailable on PPC/s390/ARM architectures [1]:

[ 0%] Building C object thirdparty/blake2/CMakeFiles/blake2.dir/blake2b.c.o
cd /builddir/build/BUILD/openclonk-8.1/build/thirdparty/blake2 &&
/usr/bin/cc -DHAVE_CONFIG_H -DHAVE_SSE2
-DOC_SYSTEM_DATA_DIR=\"/usr/share/openclonk\"
-I/builddir/build/BUILD/openclonk-8.1/build/thirdparty/blake2
-I/builddir/build/BUILD/openclonk-8.1/thirdparty/blake2
-I/builddir/build/BUILD/openclonk-8.1/build/thirdparty/blake2/blake2_autogen/include
-I/usr/include/freety

Orphaning procedure for rubygem-review

Hi all.

This mail is part of the "orphaning" procedure for 'rubygem-review'
package [1].
Feel free to adopt it if interested.

[1] <a href="https://src.fedoraproject.org/rpms/rubygem-review" title="https://src.fedoraproject.org/rpms/rubygem-review">https://src.fedoraproject.org/rpms/rubygem-review</a>

xboxdrv package left

Hi all.

'xboxdrv' is now an "orphaned" package.
Feel free to adopt it if needed.

Orphaning procedure for mMass

Hello everyone.

This is part of the "orphaning" procedure of mMass according to
guidelines:
<a href="https://fedoraproject.org/wiki/Orphaned_package_that_need_new_maintainers#Orphaning_Procedure" title="https://fedoraproject.org/wiki/Orphaned_package_that_need_new_maintainers#Orphaning_Procedure">https://fedoraproject.org/wiki/Orphaned_package_that_need_new_maintainer...</a>

mMass development has been officially ended. There will be no further
updates, bug fixes or support from upstream, so its rpms will not longer
maintained.

Python2 and Python3 SCons

Hi all.

It seems that we need separated Python2 and Python3 SCons scripts,
that's, Scons built with Python2 does not work with Python3 code and
viceversa.

For that reason, i have rebuilt Scons in two different packages with
Python2 and Python3 in Fedora; with Python2 only on Epel7.
<a href="http://copr-fe.cloud.fedoraproject.org/coprs/sagitter/ForTesting/build/691292/" title="http://copr-fe.cloud.fedoraproject.org/coprs/sagitter/ForTesting/build/691292/">http://copr-fe.cloud.fedoraproject.org/coprs/sagitter/ForTesting/build/6...</a>

'python2-scons' (also distributes as 'scons') makes obsolete older
packaging releases of 'scons'.
'python3-scons' (or 'scons-python3') for compiling Python3 code.

Any comment or disapproval before to make these changes effective on
Fe

How to manage a fork

Hi all.

I have created a fork on <a href="https://src.fedoraproject.org/" title="https://src.fedoraproject.org/">https://src.fedoraproject.org/</a> but i don't know
how to manage it.
Can i use 'fedpkg'?
Documentation?

'texlive-pdftex-bin' broken dependencies

Hi all.

This broken dependency is on rawhide since three days at least:

Root log:
<a href="https://koji.fedoraproject.org/koji/getfile?taskID=23096680&amp;volume=DEFAULT&amp;name=root.log" title="https://koji.fedoraproject.org/koji/getfile?taskID=23096680&amp;volume=DEFAULT&amp;name=root.log">https://koji.fedoraproject.org/koji/getfile?taskID=23096680&amp;volume=DEFAU...</a>

'configure' error on x86_64/ppc64 only

Hi all.

'configure' command of 'mld2p4' package is failing on Rawhide
x86_64/ppc64 only with:

It happens on koji, not with 'rpmbuild' and 'mock'.

Can anyone get 'config.log' from build
<a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=22829601" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=22829601">https://koji.fedoraproject.org/koji/taskinfo?taskID=22829601</a> ?

'Unknown DWARF' messages (bz#1506949)

Hi all.

I don't know how to manage this kind of message:

dwz: ./usr/lib64/libpsb_prec.so.3.5.0.debug: Unknown DWARF DW_OP_253
dwz: ./usr/lib64/openmpi/lib/libpsb_prec.so.3.5.0.debug: Unknown DWARF
DW_OP_253
dwz: ./usr/lib64/openmpi/lib/libpsb_krylov.so.3.5.0.debug: Unknown DWARF
DW_OP_253
dwz: ./usr/lib64/openmpi/lib/libpsb_base.so.3.5.0.debug: Unknown DWARF
DW_OP_253
dwz: ./usr/lib64/openmpi/lib/libpsb_util.so.3.5.0.debug: Unknown DWARF
DW_OP_253
dwz: ./usr/lib64/libpsb_krylov.so.3.5.0.debug: Unknown DWARF DW_OP_253
dwz: ./usr/lib64/mpich/lib/libpsb_prec.so.3.5.0.debug: Unknown DWARF
DW_OP_

Reviews swap

Hi all.

I have two packages ready for review:
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1506949" title="https://bugzilla.redhat.com/show_bug.cgi?id=1506949">https://bugzilla.redhat.com/show_bug.cgi?id=1506949</a>
<a href="https://bugzilla.redhat.com/show_bug.cgi?id=1506986" title="https://bugzilla.redhat.com/show_bug.cgi?id=1506986">https://bugzilla.redhat.com/show_bug.cgi?id=1506986</a>

I can review other packages in return.

Update to MUMPS-5.1.2

Hi all.

I'm going to update MUMPS to the latest release 5.1.2 on rawhide this
weekend.