DevHeads.net

Postings by Mark Fraser

Laptop touchpad buttons stopped working

The touchpad buttons on my daughter's laptop running Kubuntu 16.10, but I am
also unable to click on anything using a USB or Bluetooth mouse either. I have
even tried a live USB of 17.04, but nothing is working.

Sounds like a hardware problem, but why don't USB or Bluetooth mouses work
either?

libmarblewidget

Trying to install a package in 16.04 that requires libmarblewidget-qt5-23, but
it can't be installed as it wants to install libastro1 version
4:15.12.3-0ubuntu2. As I have the backports PPA enabled, I have version
4:16.04.3-0ubuntu2~ubuntu16.04~ppa63.

Does libmarblewidget-qt5-23 need to be added to the backports PPA with updated
depends?

Problems since upgrading to 16.04

After upgrading to 16.04 I was unable to use anything that required Akonadi as
it kept crashing. I tried various things to get it working again, but in the
end I decided to create a new user profile.

This has worked apart from 3 continuing problems:
1) I have been unable to get indexing of my emails working again.

2) I no longer have the option in Amarok of deleting or moving a track to the
waste bin from the context menu.

Unable to start KMail after upgrade to 16.04

Upgraded to 16.04 yesterday and now I am unable to use KMail or that part
of Kontact. Akonadi says something about not being able to connect to the
database. I've tried moving .config/akonadi and .local/share/akonadi and
starting akonadi, but it doesn't help.

Altering /etc/network/interfaces stops some apps from working

In previous versions of Kubuntu I've created a static IP address by adding the interface to /
etc/network/interfaces like:

# interfaces(5) file used by ifup(8) and ifdown(8)

1) KMail was unable to fetch any images and clicking on a link in KMail brought up a "file
not found" error.

2) Akregator wouldn't fetch from any feeds.

3) I couldn't open a link from Konsole.

For now I have had to use network manager to configure a staic IP address, but is this a
bug or am I doing something wrong?

Can't compose email

No idea what I've done but I can no longer compose or reply to an email in
KMail, whenever I try to KMail crashes. This is with Kubuntu 15.10 and all
updates.

I've logged in as a different user and KMail works fine for the other user,
so it is limited to myself. Any idea what files I could try moving to try
to solve this?

Can't start Akonadi after upgrading to 15.10

Decided to upgrade to 15.10 this afternoon and now that I'm on 15.10 I am
unable to start Akonadi. If I run Akonadi Console, I get the error "

Failed to connect to database: Can't connect to local MySQL server through
socket '/tmp/akonadi-mfraser.Ak41ik/mysql.socket' (2) QMYSQL: Unable to
connect"

twice and that's about it.

Can anyone help me?

All Wine software now in Lost & Found

Since upgrading to 15.04 I've noticed that all my
software that runs under Wine is now located in the
Lost & Found menu. Is there any way of getting it
back?

Users missing from User Manager

I finally upgraded to 15.04 last week and I'm just about getting on with
it - hopefully 15.10 will be a big improvement.

One thing that has got me confused is that I have 3 users on this
computer and if I go into User Manager on my account, one of them is
missing. All 3 users appear at the login screen and if I log in to that user's
account all 3 users are visible.

Packages with broken dependencies

Finally upgraded to 15.04 and have noticed that quite a few plasma-
widget packages are no longer installable as they depend upon
plasma-scriptengine-python which isn't in the 15.04 (and 15.10)
repository. This seems to be due to KDE5 only supporting Qt5.

Is it therefore worth removing these packages from 15.10 as no one
is going to be able to install them?

Kubuntu 14.10 end of life

Kubuntu 14.10 goes end of life today and after
trying Kubuntu 15.04 on a laptop, I have no interest
in moving over to KDE 5 as a lot of things I use every
day don't seem to be working.

Is there any way I can have the security updates
without moving to 15.04?

Ark producing unreadable zip files

The other day I tried to compress some files to a zip file using Ark, but when
I tried to open them on another computer using different software, they
couldn't be read. Going back to the zip file and testing them on the command
line with unzip produces this:

End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive.

Calligra 2.9 Kubuntu backports PPA

Been trying to upgrade Calligra to 2.9 using the backports PPA this afternoon,
but it keeps failing with calligrasheets:

The following extra packages will be installed:
calligrasheets
Suggested packages:
khelpcenter
The following NEW packages will be installed
calligrasheets
0 to upgrade, 1 to newly install, 0 to remove and 0 not to upgrade.
10 not fully installed or removed.
Need to get 0 B/3,778 kB of archives.
After this operation, 14.2 MB of additional disk space will be used.
Do you want to continue? [Y/n]

(Reading database ...

Print service is unavailable bad file descriptor

I've recently started seeing the error "Print service is unavailable bad file
descriptor" when trying to print or when going into Printers in Settings. I've
been able to get it working again by restarting cups, but I shouldn't need to.

There's this <a href="https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1393281" title="https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1393281">https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1393281</a> bug
report on Launchpad, but that has expired.

Is anyone else seeing this or know how to solve it?

Kubuntu 15.04

Currently doing a clean install of Kubuntu 15.04 on an unused Netbook and here
are my first thoughts:
1) I don't like the new hourglass cursor as it is static

2) Part way through the install, the screen locker kicked in and you're shown
a screen with a box in which to enter a password. A new user to Kubuntu will
have no idea that you can simply hit return here go get back to the install.
Should the screen locker be disabled during the install procedure?

3) Love the new splash screen when loading up Kubuntu.

.local/share oddities

Just gone into my .local/share directory after thinking that I have lost some
emails only to find that local-mail contains no files, just 3 folders cur, new
and tmp which are also empty. I also have a .local-mail.directory which does
seem to hold my emails.

Strangely, every other directory in .local/share such as akonadi, icons, Trash
etc. also has the 3 directories cur, new and tmp.

Any idea what is going on?

Kajongg 4.13.2

Been trying to update Kajongg to 4.13.2 from the Kubuntu updates PPA for the
past few days, but it fails.

Information about this system

Going into "Information about this system" in system settings I get an odd
result for Processors:
1 x AMD FX(tm)-4100 Quad-Core Processor, 3 x AMD FX(tm)-4100 Quad-Core
Processor

Why not 4 x AMD FX(tm)-4100 Quad-Core Processor?

Muon updater

Been trying to remember to report this bug for a while, but keep forgetting to
do a screen grab.

The menu in Muon updater seems to change for no apparent reason with "Check
for Updates" changing from the bottom to the top.

<a href="https://bugs.kde.org/show_bug.cgi?id=333424" title="https://bugs.kde.org/show_bug.cgi?id=333424">https://bugs.kde.org/show_bug.cgi?id=333424</a>

Kubuntu 14.04 webcam

I've just noticed that in the Multimedia section of the system settings, there
are no devices visible under video recording. This is on my desktop and laptop
running 14.04, on another desktop running 13.10 there is a webcam.

This also seems to be affecting Kdenlive where there are no V4L2 detected
devices.

LibreOffice

With the latest updates of LibreOffice to 4.2.3 rc2, I am unable to get it to
start from the launcher. It shows the splash, the window opens and that's as
far as it gets.

It does run from within Konsole, but it looks as if the Oxygen style isn't
showing.

Kubuntu 14.04

I've been running 14.04 on my laptop for a while now and decided it was about
time I installed it on my desktop (was hoping it would get rid of this
<a href="https://bugs.kde.org/show_bug.cgi?id=326480" title="https://bugs.kde.org/show_bug.cgi?id=326480">https://bugs.kde.org/show_bug.cgi?id=326480</a> bug).

With the updater still showing 3 hours left on the upgrade, I went away for a
few minutes. When I came back, the updater window had vanished with the reboot
icon showing in the tray, but none of the packages had been configured as I
had to go into Konsole and type sudo apt-get -f install.

Also I seem to have both kid3 and kid3-qt apps in the menu, but only kid3 is
installed.

Firefox showing Gnome icons

Since installing Solaar[1] to Kubuntu 13.04 recently, my back and forwards
icons in Firefox have changed from the Oxygen themed ones to the default Gnome
ones. I've tried various things to get them back, but without any success.

[1] <a href="https://launchpad.net/~daniel.pavel/+archive/solaar" title="https://launchpad.net/~daniel.pavel/+archive/solaar">https://launchpad.net/~daniel.pavel/+archive/solaar</a>

Nepomuk errors KDE 4.11

Recently upgraded Kubuntu 13.04 to KDE 4.11 and I've started getting errors
from Nepomuk in the sys logs.

kernel: [ 9708.593041] nepomukindexer[29704]: segfault at 570 ip
00007fe34b77816e sp 00007fff11afe400 error 4 in
libQtGui.so.4.8.4[7fe34b370000+a60000]

Which is repeated every 3-4 seconds. Tried doing an Internet search, but
nothing is coming up.

Any ideas?

KDE 4.11 can't change order of "open with"

Up until upgrading to 4.11 today I have been able to load a CSV file into
KWrite by just double-clicking on it as it is the top entry in the application
preference order.

Since upgrading no matter what I do, Libreoffice Calc and Calligra Sheets
appear in the list above KWrite. CSV seems to be the only filetype affected.

timeout: killing '/usr/sbin/alsactl restore

Over the past week or so when I turn the computer (Kubuntu 13.04 64 bit) on
and log in, most of the desktop isn't functional - the menu will take ages to
load up, shutting down doesn't work and I have no sound - usually, but not
always simply rebooting works.

I have tracked the problem down to the following line in syslog:
udevd[443]: timeout: killing '/usr/sbin/alsactl restore 3' [1036]

Followed by these lines:
udevd[443]: last message repeated 61 times
udevd[443]: last message repeated 7 times

I did a bit of Googling and found that running:
sudo rm /var/lib/alsa/asound.state
Allows it

Kubuntu mugs

If I was to get some mugs printed with the new logo on them and I am happy
with the results, do I need any permission to sell the mugs on to anyone who
wants them?

Muon updater

Since upgrading to version 1.9.95 of muon-updater from the Kubuntu backports
PPA in Kubuntu 12.10 I've been unable to update anything. I get 3-4 windows
popping up upon loading saying that I'm about to login to opendesktop and when
I click on the tick to update the progress bar moves across, but nothing gets
updated.

Kubuntu installation general observations

I have done 3 installs of Kubuntu over the past week (12.10 32 bit, 12.10 64
bit and 13.04 64 bit) and I have some general observations of this post
install.

1) It doesn't seem possible to enable "Set date and time automatically" in the
Date & Time control module. It fails with an error after clicking on OK or
Apply. I have tried searching bugs.kde.org, but some say it should be fixed
already.

2) In System Settings > Application Appearance and Oxygen configure, why is
"Windows' drag mode" set to Drag windows from all empty areas?

Kubuntu mug help

I was washing up my Kubuntu mug that I bought from the Ubuntu store last night
and I heard the handle start to crack. Now that the store no longer stocks
Kubuntu items, is there an alternative source of these mugs?