DevHeads.net

Postings by Walter H.

Strrange behavior of VirtualHosts in Apache (Apache 2.2.15 - CentOS6)

Hello,

there is a short explanation about virtual hosts in Apache ...
<a href="https://wiki.centos.org/TipsAndTricks/ApacheVhostDefault" title="https://wiki.centos.org/TipsAndTricks/ApacheVhostDefault">https://wiki.centos.org/TipsAndTricks/ApacheVhostDefault</a>

the `hostname` gives a different donmain name than what should be hosted ...
e.g.

Strrange behavior of VirtualHosts in Apache (CentOS6)

Hello,

there is a short explanation about virtual hosts in Apache ...
<a href="https://wiki.centos.org/TipsAndTricks/ApacheVhostDefault" title="https://wiki.centos.org/TipsAndTricks/ApacheVhostDefault">https://wiki.centos.org/TipsAndTricks/ApacheVhostDefault</a>

the `hostname` gives a different donmain name than what should be hosted ...
e.g.

Advice for storage location ...

Hello,

I have an incoming mailserver, and there I'm implementing a mailfilter,
which I did like this:
<a href="http://www.postfix.org/FILTER_README.html#simple_filter" title="http://www.postfix.org/FILTER_README.html#simple_filter">http://www.postfix.org/FILTER_README.html#simple_filter</a>

there they use /var/spool/filter
in this sample script the temporary file is deleted;
can I keep it there for a short time (1 week)?

Thanks,
Walter

CentOS6, IP6tables, Routing, TPROXY (squid34 epel package)

Hello,

how do achieve this:

how must files /etc/sysconfig/network-scripts/ look like to be the same as
entering the following two commands ...
ip -f inet6 rule add fwmark 1 lookup 100
ip -f inet6 route add local ::/0 dev lo table 100
is there the localhost device lo correct, or does it have to be br0?

e.g.
a file route-br0 with
192.168.1.0/24 via 10.10.10.1 dev br0
does the routing to the segment 192.168.1.0/24 via 10.10.10.1

/etc/sysconfig/ip6tables
<BEGIN>
*mangle
:PREROUTING ACCEPT [0:0]
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:POSTROUTING ACCEPT [0:0]

-N DIVERT

Messages during update 'yum update' at CentOS 6 VM

Hello,

at the last update (Kernel updated
from 2.6.32-696.3.2.el6.x86_64 to 2.6.32-696.6.3.el6.x86_64)
I got these messages

Updating : ipv6calc-1.0.0-20.el6.x86_64 6/25
/var/tmp/rpm-tmp.yi7R81: line 1: /usr/sbin/ldconfig: No such file or
directory
warning: %post(ipv6calc-1.0.0-20.el6.x86_64) scriptlet failed, exit status
127
Non-fatal POSTIN scriptlet failure in rpm package
ipv6calc-1.0.0-20.el6.x86_64

Cleanup : ipv6calc-0.99.2-17.el6.x86_64 25/25
/var/tmp/rpm-tmp.i7G3si: line 1: /usr/sbin/ldconfig: No such file or
directory
warning: %postun(ipv6calc-0.99.2-17.el6.x86_64) scriptlet failed

what is causing this problem ... (yum, fastest mirror)

Hello,

what is causing the following, and can someone give the solution which is
mentioned at <a href="https://access.redhat.com/articles/1320623" title="https://access.redhat.com/articles/1320623">https://access.redhat.com/articles/1320623</a>

by the way: why are the "fastest" mirrors from other continent?

[root@host sysconfig]# yum clean all
Loaded plugins: fastestmirror, security
Cleaning repos: base epel extras updates
Cleaning up Everything
Cleaning up list of fastest mirrors

[root@host sysconfig]# yum clean all
Loaded plugins: fastestmirror, security
Cleaning repos: base epel extras updates
Cleaning up Everything

[root@host sysconfig]# yum update
Loaded plugins: fastestmirror, security
Se

IPv6 addresses order (CentOS6)

Hello,
in /etc/sysconfig/network-scripts/ifcfg-eth0 I have this
<ifcfg-eth0>
...
IPV6INIT=yes
IPV6ADDR=prefix::5
IPV6ADDR_SECONDARIES="prefix::2 prefix::3 prefix::4"
IPV6_AUTOCONF=no
IPV6_DEFAULTGW=prefix::1
IPV6_DEFAULTDEV=eth0
</ifcfg-eth0>
when I enter ifconfig the IPv6 addresses are in a different order
<ifconfig>
eth0 Link encap:Ethernet HWaddr ...
inet addr:... Bcast:...

CentOS6 and squid34 package ...

Hello

what is the essential difference between the default squid package and
this squid34 package,
as I have problems using this squid34 package for FTP connections;
there are no shown icons, when going to e.g.

TLSv1.3 support?

Hello,

will the next update of CentOS 6 (6.10) have TLSv1.3 support?

Thanks,
Walter

logrotate failed ... (CentOS 6.9)

I get regularily such a mail

<mail>
Anacron job 'cron.daily' on ....

/etc/cron.daily/logrotate:

error: error running non-shared postrotate script for
/var/log/clamd.clamsmtp/clamsmtpd.log of
'/var/log/clamd.clamsmtp/clamsmtpd.log '
</mail>

content of /etc/logrotate.d/clamsmtp

/var/log/clamd.clamsmtp/clamsmtpd.log {
monthly
notifempty
missingok

postrotate
pkill -SIGHUP -f clamd.clamsmtp >/dev/null 2>&1 || :
endscript
}

when looking at ls:

<ls -al /var/log/clamd.clamsmtp/>
total 572
drwxr-xr-x. 2 clamsmtp mail 4096 May 1 03:15 .
drwxr-xr-x.

CentOS 6: environment variables and cronjobs ...

Hello,

in

/etc/cron.d/test

I've this:

50 15 * * * root ( date ; echo "---" ; env ; echo "---" ; set )
and I thought I would be shown environment variables which are defined in

e.g.
/etc/profiles.d/proxy.sh or
/etc/profiles.d/proxy.csh

but this isn't like this ...

where do I have to define e.g.
export http_proxy="http://proxy.local:3128/"
in order to have it in cron jobs?

Thanks,
Walter

CentOS 6, Apache 2.2.15 and SNI?

Hello,

is Apache 2.2 which is part of the CentOS distribution capable of SNI?

I have troubles that are coming from server side (CentOS 6.8, Apache 2.2.15)
just did 'yum update'

in
/etc/httpd/conf/httpd.conf

I've the following

NameVirtualHost ipaddr:443

Include /etc/httpd/conf/vhosts/vhost-ssldom1-box.conf
Include /etc/httpd/conf/vhosts/vhost-ssldom2-box.conf

both 'vhost'-files are like this:

<VirtualHost ipaddr:443>
ServerAdmin webmaster@domain#.com

ServerName vhost.domain#.com:443
ServerAlias box.domain#.com:443
ServerAlias calcbox.domain#.com:443
ServerAlias proxybox.domain#.com:4

Keyboard layout on remote, local, ... CentOS 6; strange behaviour

Hello,

I did the following:

in /boot/grub/menu.lst I added/replaced KEYTABLE=us-acentos

in /etc/sysconfig/keyboard I have this:
KEYTABLE="us-acentos"
MODEL="pc105"
LAYOUT="us"
KEYBOARDTYPE="pc"
VARIANT="intl"

my host system is Windows; and for connecting to Linux terminal I use PuTTY

in Windows I have configured German keyboard layout;

what would someone expect, when using PuTTY to connect to the above
configured CentOS 6

I thought that there I have the US intl layout; but its German;

when I switch the keyboard layout in Windows to US intl.

IPv6 address configuration and default IPv6 address with CentOS 6.8?

Hello,

when I have this in /etc/sysconfig/network-scripts/ifcfg-eth0

TYPE=Ethernet
NAME=eth0
NM_CONTROLLED=no
ONBOOT=yes
DEVICE=eth0
USERCTL=no
...
IPV6INIT=yes
IPV6ADDR=2001:DB8:DEAD:BEEF::10
IPV6ADDR_SECONDARIES="2001:DB8:DEAD:BEEF::20 2001:DB8:DEAD:BEEF::30
2001:DB8:DEAD:BEEF::40 2001:DB8:DEAD:BEEF::50"
IPV6_AUTOCONF=no
IPV6_DEFAULTGW=2001:DB8:DEAD:BEEF::1
IPV6_DEFAULTDEV=eth0

I have a virtual server, and there are the alias addresses splitted,
e.g.

Hint for nslookup wanted ...

Hello,

has anybody a hint for me, how I can use nslookup to get
either IPv6 AAAA only or both A and AAAA entries when doing this:

e.g.

# nslookup <a href="http://www.example.com" title="www.example.com">www.example.com</a>

Thanks,
Walter

IPv6 routing with 2 different prefixes

Hello

I've got two prefixes, one /48 and one /64

let's say these two
2001:db8:0815::/48
2001:db8:4711:cafe::/64

the router has on it's ethernet interface the following to IPv6 addresses:
2001:db8:0815::1/48
2001:db8:4711:cafe::1/64

a windows box has
2001:db8:0815::17/48
and
2001:db8:0815::1
as it's gateway

a linux box has
2001:db8:4711:cafe::11/64
and
2001:db8:4711:cafe::1
as it's gateway

why can only the router do
ping6 2001:db8:0815::17
and not the linux box?

is there a missing IPv6 route?

Thanks,
Walter

/etc/sysconfig/network HOSTNAME settings

Hello,

I found different ways to define the hostname ...

this
HOSTNAME="host.domain.tld"

or this:
HOSTNAME="host"
DOMAIN="domain.tld"

what is the correct way?

Thanks,
Walter

more than one IP address on network device?

Hello

/etc/sysconfig/network-scripts/ifcfg-eth0 looks like this:

# Intel Corporation 82545EM Gigabit Ethernet Controller (Copper)
TYPE=Ethernet
NAME=eth0
NM_CONTROLLED=no
IPV4_FAILURE_FATAL=yes
UUID=cc2635ff-3c14-48ba-b19a-84c5b9d36a9d
ONBOOT=yes
DEVICE=eth0
BOOTPROTO=none
HWADDR=00:50:56:01:00:01
BROADCAST=192.168.0.255
IPADDR=192.168.0.10
NETMASK=255.255.255.0
NETWORK=192.168.0.0
GATEWAY=192.168.0.1
DNS1=192.168.0.1
DNS2=192.168.0.100
DOMAIN='domain.tld'
USERCTL=no
IPV6INIT=yes
IPV6ADDR=ipv6addr
IPV6_AUTOCONF=no
IPV6_DEFAULTGW=ipv6addr-gateway
IPV6_DEFAULTDEV=eth0

if I would need an addit

/etc/sysconfig/network HOSTNAME settings

Hello,

I found different ways to define the hostname ...

this
HOSTNAME="host.domain.tld"

or this:
HOSTNAME="host"
DOMAIN="domain.tld"

what is the correct way?

Thanks,
Walter

BIND (named) as secondary and .jnl files

Hello,

I have two running BINDs in my LAN, one on my router box and one as VM;
both are caching DNS servers, and a few zones are on both, on the box as
master and on the VM as slave,
but how can I cleanup/flush the growing .jnl files;

rndc freeze
rndc thaw

doesn't work as these are not master ...

Thanks,
Walter

info wanted about meaning of boot messages ...

Hello,

I've got CentOS 6.8 x64, updated today to the latest by 'yum update'
this installed a new kernel: 2.6.32-642.4.2.el6.x86_64

in /var/log/boot.log I found these 3 lines ...

No kdump initial ramdisk found. [WARNING]
Rebuilding /boot/initrd-2.6.32-642.4.2.el6.x86_64kdump.img
cp: cannot stat `/lib/firmware/i915/bxt_dmc_ver1.bin': No such file or
directory

the first two are logic to me, but the 3rd line, did there something
fail at the update?

Thanks,
Walter

running CGI scripts with SELinux=ENFORCING with priviledged commands ...

Hello,

how could it be achieved to run
e.g.
shutdown -h now
from a CGI script on a system where SELinux is set to ENFORCING?

Thanks
Walter

Error at sdhci-pci, kernel

Hello,

CentOS 6.8, kernel 2.6.32-642.3.1.el6.x86_64

sdhci: Secure Digital Host Controller Interface driver
sdhci: Copyright(c) Pierre Ossman
sdhci-pci 0000:00:10.0: SDHCI controller found [8086:2294] (rev 21)
sdhci-pci 0000:00:10.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
sdhci-pci 0000:00:10.0: Invalid iomem size. You may experience problems.

Manually configured Firewall (WLAN-AP plus Router)

Hello

I've got this Mini-PC
<a href="https://www.zotac.com/product/mini_pcs/zbox-ci323-nano" title="https://www.zotac.com/product/mini_pcs/zbox-ci323-nano">https://www.zotac.com/product/mini_pcs/zbox-ci323-nano</a>

everything is fine -> latest 6.8 kernel works;
both Ethernet-Interfaces work and also the WLAN-Interface works;

the two Ethernet-Interfaces are eth0 and eth1
the WLAN-Interface is wlan0

eth1 is connected on ISP side
eth0 is connected on my LAN side to a switch;
and wlan0 shall also be on my LAN side für wireless and work as an Access-Point
(this works)

I want both LAN interfaces (eth0 and wlan0) have the same IP subnet
so I did this:
<a href="http://www.microhowto.info/howto/persistently_bridge_traffic_between_two_" title="http://www.microhowto.info/howto/persistently_bridge_traffic_between_two_">http://www.microhowto.info/howto/persistently_bridge_traffic_between_two_</a>

Hardware Support of CentOS 6: Mini-PC

Hello,

can CentOS 6.8 be run on a mini-PC like this?
<a href="https://www.zotac.com/product/mini_pcs/zbox-ci323-nano" title="https://www.zotac.com/product/mini_pcs/zbox-ci323-nano">https://www.zotac.com/product/mini_pcs/zbox-ci323-nano</a>

would like to configure this as a Firewall, and this should be instead of
my router (integratet firewall, NAT) and wlan-ap

Thanks,
Walter

yum timeout ... (CentOS 6.8)

Hello,

the last times, when I tried to update,

it get time outs; even when 'yum list'

[root@host ~]# yum list
Loaded plugins: fastestmirror, security
Determining fastest mirrors
epel/metalink | 13 kB 00:00
* base: centos.den.host-engine.com
* epel: mirror.steadfast.net
* extras: centos.den.host-engine.com
* updates: centos.den.host-engine.com
<a href="http://centos.den.host-engine.com/6/os/x86_64/repodata/repomd.xml:" title="http://centos.den.host-engine.com/6/os/x86_64/repodata/repomd.xml:">http://centos.den.host-engine.com/6/os/x86_64/repodata/repomd.xml:</a> [Errno
12] Timeout on <a href="http://centos.den.host-engine.com/6" title="http://centos.den.host-engine.com/6">http://centos.den.host-engine.com/6</a>
/os/x86_64/repodata/repomd.xml: (28, 'Operation too slow.

Console screen changed on updating from CentOS 6.7 to CentOS 6.8?

Hello,

I have several CentOS 6 VMs, I have updated the first one successfully,
but there is one thing I miss or I don't like;

How do I get the standard console with 80x25 back?

Hello,

this is /boot/grub/grub.conf

default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title CentOS (2.6.32-642.el6.x86_64)
root (hd0,0)
kernel /vmlinuz-2.6.32-642.el6.x86_64 ro
root=UUID=a27dc9a0-ea3a-497d-a9c3-80c7bbba31fa rd_NO_LUKS
LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=auto
rd_NO_DM rd_NO_LVM KEYBOARDTYPE=pc KEYTABLE=de config_NO_HZ vga=0x0300
initrd /initramfs-2

Successful update from CentOS 6.7 to CentOS 6.8, but ...

Hello,

I have several CentOS 6 VMs, I have updated the first one successfully,
but there is one thing I miss or I don't like;

How do I get the standard console with 80x25 back?

this is /boot/grub/grub.conf

default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title CentOS (2.6.32-642.el6.x86_64)
root (hd0,0)
kernel /vmlinuz-2.6.32-642.el6.x86_64 ro
root=UUID=a27dc9a0-ea3a-497d-a9c3-80c7bbba31fa rd_NO_LUKS
LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 crashkernel=auto
rd_NO_DM rd_NO_LVM KEYBOARDTYPE=pc KEYTABLE=de config_NO_HZ vga=0x0300
initrd /initramfs-2.6.32-6

Looking for location of some specific settings in CentOS 6.x

Hello,

I have several virtual machines, all with CentOS 6.x and one so called
virtual server at a web hoster

my virtual machines (VMware) were all installed manually using the .iso,
some exist longer and therefore
were originally a CentOS 6.3, some are newer and wer originally a CentOS
6.6;
and this virtual server has been installed using a preconfigured image
from the web hoster;

on all this virtual machines and the virtual server several 'yum update'
brought them to same release, not CentOS 6.7,
as I havn't updated to 6.8 yet;

at the virtual server I find this

export LS_OPTIONS="--

ClamAV from EPEL

Hello,

just curious;
since March 3rd, 2016 everdays logwatch-mail
shows this:

Last Status:
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.99 Recommended version: 0.99.1

on May 4th, 2016 I updated clamav by
yum update clamav
since then the daily logwatch-mail
shows this:

Last Status:
WARNING: Your ClamAV installation is OUTDATED!
WARNING: Local version: 0.99.1 Recommended version: 0.99.2

I guess, that it happened accidentally, that I just updated the day
before ClamAV did a bigger change;
as I had tried 'yum update clamav' several times b