DevHeads.net

Postings by Jerry Geis

CentOS 7.5 and GPU memory

Is there a way to "control" how much GPU memory the OS uses ?
Back on CentOS 7.4 it "seemed" to use less. I want / need to tell 7.5 to
use less.\ or no GPU memory. I have a video application that needs more of
the GPU memory and not so much the OS taking that memory.

How do I do that?

Thanks,

Jerry

CentOS 7.5

Hi All - Just checking on "expected" 7.5 release - I'm guessing its very
close.

On a side note... I played with CR enabled it and did the update, my
/etc/redhat-release still says the old 7.4... I was thinking it would say
something different for CR.

Anyway looking forward to 7.5!

Thanks,

Jerry

Vmware - Slightly off topic

Hi All,

What is the correct way to provide a CentOS 7 - WMware image for ESX ?

As an amateur to VMware - I thought - great I can get VMplayer and ESX
should be able to import my image... Wrong... I even went through the
trouble of "converting" to VMWare workstation and thinking ESX could import
that - Apparently still Wrong... I cannot for the life of me understand
how one product family is so incompatible with itself.

xfs file system errors

How do I fix an xfs file system error ?

I searched and it says to run xfs_repair /dev/sda1 - did not work.
I got an error on boot and the machine dropped into service mode by
entering the PW. I entered the above command and it said couldnt load
library...

SO I rebooted, dropped into rescue mode. Again I entered the command above
and it said teh same thing.something about could not load library

What am I missing ? Thanks,

Jerry

pid_max

I have two systems both running CentOS 7.4

one shows pid_max as 32768
the other shows pid_max as 49152

Why might that be ? I would have thought they would be the same. I have not
changed them.

Thanks,

Jerry

virt-manager change to bridged networking on CentOS 7.4

Hi All,

I have virt-manager running just fine currently using NAT.

I want to "change" it to bridged network. The GUI is not letting me change
anything on the network section.

How do I change it to be bridged ?

Thanks,

Jerry

Question on CentoS 7.4 on nvidia

I installed the elrepo kmod-nvidia and also the nvidia-detect and modules
(see below).

I had X working with the 3.10 from Centos - but video was freezing. SO I
thought I would try the elrepo kernel. I installed that and X does not come
up?

How do I re-make the nvidia module for 4.14.5 kernel? I want to make sure
the kmod kernel did it.

yum files in /tmp

I am getting /tmp/yum_save_tx.2017-12..... files in /tmp one every hour.
What process is making these files ???
I have stopped PackageKit so its not running.

I am running CentOS 7.4. With GNOME desktop. Thanks

Jerry

Failed attempts

hi All,

I happened to login to one of my servers today and saw 96000 failed login
attempts. shown below is the address its coming from. I added it to my
firewall to drop.

Failed password for root from 123.183.209.135 port 14299 ssh2

FYI - others might be seeing it also.

Jerry

Nvidia error

I am getting this error on CentOS 7.4

kernel: NVRM: API mismatch: the client has the version 384.98, but#012NVRM:
this kernel module has the version 384.90.

Error message at times

I see this message once in a while:
Buffer I/O error on dev dm-1, logical block 8388592, async page read

I am using two crucial SSD as RAID-1 on CentOS 7.4

What should I do? can I mark that block as not usable. ?

Thanks,

Jerry

/usr/bin/x0vncserver large blocks on screen at times

I use this vnc program to remote into my station. (C 7.4)

When I do, about every 5 to 10 seconds a big solid block appears on my
screen. About six inches long and 3 inches wide. it quickly then goes away.

I use the realvnc.com viewer when I do this.

Is there some setting that would help with this ?

Jerry

Dahdi get latest

I am trying to use dahdi complete 2.11.1 with a 4.13 kernel. - NOT working
for know reasons.
I tried applying two patches but still get compile errors. AHHH!

How do I just use git to get the latest with the fixes ????

This command did not work - I still get the errors.
git clone git://git.asterisk.org/dahdi/linux dahdi-linux

Thanks,

Jerry

compile webkit

I am trying to compile webkitgtk
I downloaded the webkit source, extracted

CMake Error at Source/cmake/OptionsGTK.cmake:12 (message):
GCC 4.9.0 is required to build WebKitGTK+, use a newer GCC version or
clang

I downloaded 2.14.7 - just like CentOS 7.4 has, how can I be getting a GCC
error ?

My goal is to get the MediaSource package in webkit working. It seems to
not be enabled.
Is there a better way ?

Thanks,

Jerry

VNC into CentOS 7.4

When I VNC into 7.4 everything is fine until I run vmplayer (VMware).
The vmplayer runs but when I type on the console for vmplayer which is also
running a centos image I get multiple key presses - sometimes. Its not
everytime - but enough to be annoying.

How do I take care of that ?

Jerry

vmplayer for linux 12.5.7 on CentOS 7.4

So after the update to CentOS 7.4 vmplayer 12.5.7 is no longer working.

I can't believe after all the time that RHEL 7.4 has been released and
VMware has not fixed the issue and made a new release.

What is everyone doing that used the vmplayer on linux?

Thanks,

Jerry

webkit on CentOS 7.4

Hello is the webkit with CentOS 7.4 compiled with ENABLE_MEDIASOURCE ?

When I call the set_media_source function with TRUE and then ask
get_media_source function for the value it returns TRUE. I presume it would
no return TRUE if its not enabled.

However, my webpage with a video tag using webkit is not finding the
MediaSource.

Thanks,

Jerry

update to 7.4

I was doing an update to 7.4 and somewhere in middle the machine died.

If I drop back to a previous kernel the machine is alive. So how do I say
"forget the previous yum update" and start all over and do it again.

Booting into the new kernel I get a kernel fault. So going back one level
on teh boot screen solves that - I just need to start the update again. How
is that?

Thanks,

Jerry

vmware player 12.5.7 with CentOS 7.4

hi all - anyone find a way to get vmware player 12.5.7 working with 7.4?

Thanks - everything good with the upgrade except that.

Great job CentOS team!

Jerry

starting vmplayer I get the following:
Note: adwaita is installed.
canberra is installed
No idea what pk is ?

vmplayer

(vmware-modconfig:12595): Gtk-WARNING **: Unable to locate theme engine in
module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/main.rc:733: error: unexpected identifier
`direction', expected character `}'

(vmware-modconfig:12595): Gtk-WARNING **: Unable to locate theme engine in
module_path: "adwaita",
/usr/s

Update to 7.4 using DVD

I am attempting to update to 7.4 using the DVD

I get these errors(truncated list)
Error: Package: libgpod-0.8.3-14.el7.x86_64 (@epel)
Requires: libusbmuxd.so.2()(64bit)
Removing: usbmuxd-1.0.8-11.el7.x86_64 (@anaconda)
libusbmuxd.so.2()(64bit)
Obsoleted By: usbmuxd-1.1.0-1.el7.x86_64 (c7-media)
Not found
Error: Package: network-manager-applet-1.4.0-2.el7.x86_64 (@base)
Requires: libnma(x86-64) = 1.4.0-2.el7
Removing: libnma-1.4.0-2.el7.x86_64 (@base)
libnma(x86-64) = 1.4.0-2.el7
Upda

intel wireless 3165 and CentOS 7.3

I am trying to get wireless working on CentOS 7.3 with intel wireless 3165

ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode
DEFAULT
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state
UP mode DEFAULT qlen 1000
link/ether b8:ae:ed:77:b3:3a brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT
qlen 1000
link/ether 34:02:86:cc:a0:79 brd ff:ff:ff:ff:ff:ff
4: virbr0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state
DOWN

Centos 7 Install

I have a Centos 7 install that seems to be filling up disk space to 100% on
the root partition.

in /tmp I found files of names...
systemd-private-XXXXXXXX-colord and rtkit
I have never seen these files before.

there were also files of XXXXXXXXXXXXX.tmp in the /tmp folder.

Why are these files appearing? I have a number of installs and never came
across this before.

Thanks,

Jerry

Custom kickstart post section on usb thumbdrive

Hi All,

I am attempting to create a custom USB drive for kickstart install.

I found this:
1. get the ISO file of CentOS 7

2. mount -o loop CentOS-7.0*.iso /mnt/

3. mkdir -p
/CentOS-7-ISO-respin/{CentOS-7-unpacked,CentOS-7-iso}

4. rsync -avz /mnt/ /CentOS-7-ISO-respin/RHEL-7-unpacked

5. put your kickstart file into
/CentOS-7-ISO-respin/RHEL-7-unpacked

6.

CentOS 7.3 and e1000e

Hi All - I have a box running the above. Power was lost long enough that
UPS did not work. When power came back on the C7 box boots way faster than
the switch and resulted in no network. power cycling the C7 box resulted in
network.

This even happened a second time. The only way to get the box back was to
power cycle. the box is remote and no keyboard and mouse connected.

Any thoughts on why the e1000e would not talk to the switch ? The switch is
an unmanaged linksys - could not get the model.

Updating to CentOS 7.3

I have remote systems that need updating. C5 and C6 systems.

Is there a "method" that is out there that you can load an ISO of 7.3 on a
different partition (other than root) tell the boot up process that the ISO
is there, do a clean install, install everything, auto reboot, and now C7
is installed and running.

Some configuring will be required after - but that is fine.

Crazy thought about upgrading to new major release

I have older systems out there that work fine, just for what ever reason
would be great to upgrade from a C5 -> C7 (due to no longer supported) or
C6 > C7 (for updated packages).

Sounds like the upgrade tool is not quite an option...
I was thinking...

What would be wrong with any "easy" script that did the following:

1) Removed all packages with the --justdb option.
2) Import the RPM-GPG-KEY-CentOS-7
3) install the centos-release-7.3.1611 ...

Upgrade 6 to 7

I found this site <a href="https://wiki.centos.org/TipsAndTricks/CentOSUpgradeTool" title="https://wiki.centos.org/TipsAndTricks/CentOSUpgradeTool">https://wiki.centos.org/TipsAndTricks/CentOSUpgradeTool</a>

Is this still the case - there is no upgrade path from 6 to 7 ?

I have a few remote servers I'd like to upgrade (if possible).

Thanks,

Jerry

CentOS 7 and sound

Hello,

I have a need to get CentOS 7 sound working on a console only machine. X is
not running.

Currently when I try aplay:
aplay /usr/share/sounds/alsa/Front_Center.wav
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect:
Connection refused

aplay: main:786: audio open error: Connection refused

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

So sound is present - I presume pulseaudio is not running as X is not
running,

Can I run audio without X ?

Basic authentication - maybe off topoc

Hi - I am using CentOS 7.3 and trying to receive basic authentication.

I run a command liked: curl -X POST -u jerry:pw
<a href="http://192.168.1.8/inbound.cgi" title="http://192.168.1.8/inbound.cgi">http://192.168.1.8/inbound.cgi</a>

When I use printenv in the cgi I do not see the user and password anywhere.
Isn't it supposed to be there in an environment variable like REMOTE_USER ?

How do I receive the basic authentication ?

Thanks,

Jerry

Chrome version 28 for CentOS 6 or last official version that worked on C6

Anyone know where I can download version 28 of chrome for C6?

I know there are "other" ways to get the latest... and install on C6...
I know version 28 is old and unsupported and all that...

But that is what I need.

I think it was the last official build that worked on C6 "as is".

Thanks for your help.

jerry