DevHeads.net

Postings by Sascha Manns

publican_creators 1.2.0 released!

publican_creators 1.2.0 has been released.

* home <https://launchpad.net/publicancreators>
* bugs: <https://bugs.launchpad.net/publicancreators>
* questions: <https://answers.launchpad.net/publicancreators>
* doc: <http://www.rubydoc.info/gems/publican_creators>
* userdoc: <https://saigkill.github.io/publican_creators/about/>

This program works on top of Redhat's publican. It helps by creating a
new project and replaces the default values to your own values. Also it
provides a graphical creator for new projects, a graphical project
builder and a graphical revision editor.

hoe-reek 1.2.1 released!

hoe-reek 1.2.1 has been released.

* home <https://launchpad.net/hoe-reek>
* bugs: <https://bugs.launchpad.net/hoe-reek>
* questions: <https://answers.launchpad.net/hoe-reek>
* doc: <http://www.rubydoc.info/gems/hoe-reek>
* userdoc: <https://saigkill.github.io/hoe-reek/about/>

Tasks to integrate the reek code smell engine into your hoe projects.
This project continues erics project (<a href="https://github.com/erikh/hoe-reek" title="https://github.com/erikh/hoe-reek">https://github.com/erikh/hoe-reek</a>
).

Try it out: `gem install hoe-reek`

Changes:

* 2 minor enhancements

* updated dependencies
* updated docs

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject

hoe-packaging 1.2.1 released!

hoe-packaging 1.2.1 has been released.

* home <https://launchpad.net/hoe-packaging>
* bugs: <https://bugs.launchpad.net/hoe-packaging>
* questions: <https://answers.launchpad.net/hoe-packaging>
* doc: <http://www.rubydoc.info/gems/hoe-packaging>
* userdoc: <https://saigkill.github.io/hoe-packaging/about/>

hoe-packaging is a plugin for the hoe ruby projecthelper (<a href="https://githu" title="https://githu">https://githu</a>
b.com/seattlerb/hoe).

hoe-manns 2.1.0

hoe-manns 2.1.0 has been released.

* home <https://launchpad.net/hoe-manns>
* bugs: <https://bugs.launchpad.net/hoe-manns>
* questions: <https://answers.launchpad.net/hoe-manns>
* doc: <http://www.rubydoc.info/gems/hoe-manns>
* userdoc: <https://saigkill.github.io/hoe-manns/about/>

hoe-manns is a small collection of my personal used rake tasks for
using with hoe (a plugin for the hoe rake/rubygems helper for project
Rakefiles (<a href="https://github.com/seattlerb/hoe" title="https://github.com/seattlerb/hoe">https://github.com/seattlerb/hoe</a>).

Try it out: `gem install hoe-manns`

Changes:

=== 2.1.0 / 2017-10-25

* 5 minor enhancements

* HM-9: Split module into two

TopIcons doesn't work with X.Org session [artful]

Hello list,

i have seen a interesting thing on artful.

If i'm using the Ubuntu Session with Wayland, the Apps (like Shutter,
Nixnote, Tomboy ...) are visible in the TopIcons place on the right
side.

If i'm using the Ubuntu Session with XOrg, that Apps aren't visible.

Is there a different handling of such icons between Wayland and XOrg?

Greetings
Sascha

ubuntu dock error [artful]

Hello list,

last time i used zesty with gnome3 desktop.

Now i upgraded to 17.10 with ubuntu-session. Sadly the Ubuntu Dock
isn't visible.

I checked out <a href="https://extensions.gnome.org/local/" title="https://extensions.gnome.org/local/">https://extensions.gnome.org/local/</a>. There the Ubuntu
Dock is visible as System Extension. But no option to enable it. Just a
red "Error" box.

How can i debug, what happend?

Greetings
Sascha

youtube_dlhelper 3.0.0

youtube_dlhelper 3.0.0 has been released.

* home: <https://launchpad.net/youtube-dlhelper>
* bugs: <https://bugs.launchpad.net/youtube-dlhelper>
* questions: <https://answers.launchpad.net/youtube-dlhelper>
* doc: <http://www.rubydoc.info/gems/youtube_dlhelper>
* userdoc: <https://saigkill.github.io/youtube_dlhelper/about>

The youtube_dlhelper is a short tool for download and manage the
downloaded files. You are running the program inside the command line
with a Youtube URL. Then it asks for a group name or interpreters name.
Now it creates a Subfolder inside your Musicdirectory.

Using a gem from git

Hello list,

because the upstream developer of youtube-dl.rb doesn't provide the
latest binaries, i'm using this one <a href="https://github.com/n1ckbren/youtube" title="https://github.com/n1ckbren/youtube">https://github.com/n1ckbren/youtube</a>
-dl.rb.

In my Gemfile i have added:
gem "youtube-dl.rb", "~>0.3.1.2017", :git => 'https://github.com/n1ckbr
en/youtube-dl.rb'.

After doing a bundle install i have in my Gemfile.lock:
GIT
  remote: <a href="https://github.com/n1ckbren/youtube-dl.rb" title="https://github.com/n1ckbren/youtube-dl.rb">https://github.com/n1ckbren/youtube-dl.rb</a>
  revision: b8423e3713f7f5f74a52fc987c324178315a8d78
  specs:
    youtube-dl.rb (0.3.1.2017.06.25)
      cocaine (>= 0.5.4)

GEM
[...]

DEPENDENCIES
[...]
youtube-dl.rb (~> 0.3.1.2017)!

Now i created a new

Downgrading bundler

Hello list,

i have used bundle install with a installed bundler 1.16.0.pre.3. Now i
would like to use the standard bundler 1.15.4.
So i removed the pre from the gems dir in rvm. A new bundle install
gives me:
/home/sascha/.rvm/gems/ruby-2.4.1/bin/bundle:23:in `load': cannot load
such file -- /home/sascha/.rvm/gems/ruby-2.4.1/gems/bundler-
1.16.0.pre.3/exe/bundle (LoadError)

How can i tell the gem, that it should use the old one?

Greetings
Sascha

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

Rubocop Require parantheses

Hello list,

i'm using in a test:
expect(ffmpeg_binary).equal? '/usr/bin/ffmpeg' || '/usr/bin/avconv'

Rubocop says now:
Lint/RequireParentheses: Use parentheses in the method call to avoid
confusion about precedence.

How would this looks like correct?

expect(ffmpeg_binary).equal? {'/usr/bin/ffmpeg'} || {'/usr/bin/avconv'}

Greetings
Sascha

Unsubscribe: <mailto:ruby-talk-request@ruby-lang.org?subject=unsubscribe>
<http://lists.ruby-lang.org/cgi-bin/mailman/options/ruby-talk>

Release not found

Hello list,

sometimes if i'm adding a new repository and make a apt update, i'm
getting errors like:

Fehl:20 <a href="http://ppa.launchpad.net/utappia/stable/ubuntu" title="http://ppa.launchpad.net/utappia/stable/ubuntu">http://ppa.launchpad.net/utappia/stable/ubuntu</a> zesty
Release          
  404  Not Found
Paketlisten werden gelesen... Fertig
N: Skipping acquire of configured file 'main/binary-i386/Packages' as
repository 'file:/var/cache/apt-build/repository apt-build InRelease'
doesn't support architecture 'i386'
E: The repository 'http://ppa.launchpad.net/utappia/stable/ubuntu zesty
Release' does not have a Release file.

But why that happens?

Greetings
Sascha

Makefile: missing separator

Hello list,

i'im using that lines in a Makefile.am for my new project:

# AppData
@INTLTOOL_XML_RULE@
@APPSTREAM_XML_RULES@
appdatadir = $(datadir)/appdata
appdata_in_files = org.gnome.Publisher.appdata.xml.in
appstream_XML = $(appstream_in_files:.appdata.xml.in=.appdata.xml)

The created Makefile looks like:
# AppData
%.xml: %.xml.in $(INTLTOOL_MERGE) $(wildcard
$(top_srcdir)/po/*.po) ; $(INTLTOOL_V_MERGE)LC_ALL=C $(INTLTOOL_MERGE)
$(INTLTOOL_V_MERGE_OPTIONS) -x -u -c
$(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@
@APPSTREAM_XML_RULES@
org.gnome.Publisher.gresour

Flatpak problem

Hello list,

today i tried out in the console:

flatpak remote-add --from gnome-nightly <a href="https://sdk.gnome.org/gnome-nig" title="https://sdk.gnome.org/gnome-nig">https://sdk.gnome.org/gnome-nig</a>
htly.flatpakrepo

But i'm got:

Can't load file gnome-nightly: No such file or directory

A wget works:

sascha@sascha-desktop:~/Downloads$ LANG=C wget <a href="https://sdk.gnome.org/gn" title="https://sdk.gnome.org/gn">https://sdk.gnome.org/gn</a>
ome-nightly.flatpakrepo

--2017-03-10 00:29:06--  https://sdk.gnome.org/gnome-nightly.flatpakrep
o

Resolving sdk.gnome.org (sdk.gnome.org)... 209.132.180.169

Connecting to sdk.gnome.org (sdk.gnome.org)|209.132.180.169|:443...
connected.

HTTP request sent, awaiting response...

Epiphany & Importing Bookmarks

Hello List,

is there any way to import bookmarks in epiphany from a file?
I'll checked the menu, but it looks like, that i just can save one url
as bookmark at a time. But now way to import more from a file.

Greetings
Sascha

-- 
Sascha Manns
Email: <a href="mailto:Sascha. ... at mailbox dot org">Sascha. ... at mailbox dot org</a> | Blog: <a href="http://saigkill.tuxfamily.org" title="http://saigkill.tuxfamily.org">http://saigkill.tuxfamily.org</a>
GPG: 0x168428cdb1f20ab1

Net::ReadTimeout (Net::ReadTimeout)

Hello list,

i'm using a gem (pony) which uses net-protocol.

Intltool to gettext

Hello list,

sorry for the encrypted mail. Used the false button.

Here the original message:

just now i'm a little bit irritated. 
In that article <a href="https://wiki.gnome.org/MigratingFromIntltoolToGettext" title="https://wiki.gnome.org/MigratingFromIntltoolToGettext">https://wiki.gnome.org/MigratingFromIntltoolToGettext</a>
it is proposed to remove all intltool stuff in the configs. Also it
should removed @INTLTOOL_DESKTOP_RULE@ and @INTLTOOL_XML_RULE@.

In this article <a href="https://wiki.gnome.org/Initiatives/GnomeGoals/AppDataGn" title="https://wiki.gnome.org/Initiatives/GnomeGoals/AppDataGn">https://wiki.gnome.org/Initiatives/GnomeGoals/AppDataGn</a>
omeSoftware it is mentioned to use that rules for managing the appdata
file.

But now, what to do?

Intltool to gettext

Hello list,

just now i'm a little bit irritated.
In that article <a href="https://wiki.gnome.org/MigratingFromIntltoolToGettext" title="https://wiki.gnome.org/MigratingFromIntltoolToGettext">https://wiki.gnome.org/MigratingFromIntltoolToGettext</a>
it is proposed to remove all intltool stuff in the configs. Also it
should removed @INTLTOOL_DESKTOP_RULE@ and @INTLTOOL_XML_RULE@.

In this article <a href="https://wiki.gnome.org/Initiatives/GnomeGoals/AppDataGn" title="https://wiki.gnome.org/Initiatives/GnomeGoals/AppDataGn">https://wiki.gnome.org/Initiatives/GnomeGoals/AppDataGn</a>
omeSoftware it is mentioned to use that rules for managing the appdata
file.

But now, what to do? Is there any newer handling for the appdata files?
And is this the right list?

Greetings
Sascha

Python import error

Hello List,

i'm trying to run that python script:
<a href="https://github.com/mono/mwf-designer/blob/master/deps/Mono.Design/generate-mono-design.py" title="https://github.com/mono/mwf-designer/blob/master/deps/Mono.Design/generate-mono-design.py">https://github.com/mono/mwf-designer/blob/master/deps/Mono.Design/genera...</a>

But by running that it breaks with "ImportError: No module named
request". python3-urllib3 and python-urllib3 are installed.

Maybe anyone knows, how to fix it?

Greetings
Sascha

NuGet Location

Hello List,

actually i'm experimenting a with C# on Mono.

I've seen, that exists a .config/NuGet/NuGet.config. So i'm guessing
that exists a NuGet.exe anywhere.

Does anyone knows where the bin is located and/or which package provides it?

Greetings
Sascha

kde-telepathy can't load module

Hello list,

i'm trying to add a jabber account to my instant messaging telepathy. But
after clicking on the add button i'm getting: "The module
ktpaccountskcm_plugin_kaccounts can't be loaded. Please check your
installation."

Does anyone knows how to fix this?

Greetings
Sascha