DevHeads.net

Postings by Lukas Zapletal

Autoconf help: missing X11 dependency

Hello,

my package "workrave" won't build with Rawhide, configure script complains:

checking for X... no
configure: error: X11 required on Unix platform

However it keeps complaining even when I add BuildRequires: libX11-devel. I don't understang which particular (sub)library it needs, generated configure is a bit unreadable (really!) and even debugging it with +x is not really helpful as it is a storm of tests. Any idea how to debug this? What X11 library am I missing? Any recent changes in the X11 libraries?