DevHeads.net

Postings by renee ko

httpd running with uid - apache 2.4.29

All,

I am experimenting a scratch install of Apache 2.4 on RHEL. I noticed the
httpd process is running with UID instead of username. Any ideas?

root 30426 1 0 14:40 ? 00:00:00
/app/apache/apache24/bin/httpd -k start
30139 30427 30426 0 14:40 ? 00:00:00
/app/apache/apache24/bin/httpd -k start
30139 30428 30426 0 14:40 ? 00:00:00
/app/apache/apache24/bin/httpd -k start
30139 30429 30426 0 14:40 ? 00:00:00
/app/apache/apache24/bin/httpd -k start

The httpd.conf file has the user and group configured as apache

upgrade or new install

All,

Looking for best practice upgrade method from Apache 2.2.29 to Apache
2.4.29.

Should i perform an in place upgrade or install a new version of Apache
2.4.29?

apache httpd2.4.29 error when running make command

Hello group,

I am getting following error when running the make command for httpd2.4.28
on RHEL6

Please advice.

*make[2]: Entering directory
`/app/apache/httpd-2.4.29/support'/app/apache/httpd-2.4.29/srclib/apr/libtool
--silent --mode=link gcc -std=gnu99 -g -O2 -pthread -o htpasswd
htpasswd.lo passwd_common.lo
/app/apache/httpd-2.4.29/srclib/apr-util/libaprutil-1.la
<http://libaprutil-1.la> /app/apache/httpd-2.4.29/srclib/apr/libapr-1.la
<http://libapr-1.la> -lrt -lcrypt -lpthread
-lcrypt/app/apache/httpd-2.4.29/srclib/apr-util/.libs/libaprutil-1.so:
undefined refe

stable version of 2.4 running in production?

I am planing to upgrade Apache from 2.2 to 2.4 on RHEL 6.6.

I am looking for best practice, should i perform an upgrade from 2.2 or
install 2.4?

Thank you.

Apache load module path

Team,

I have LoadModules configured under the default RedHat httpd directory.

Example:
LoadModule proxy_module /usr/lib64/httpd/modules/mod_proxy.

I would like the modules to be changed to another
directory(/usr/local/apache2/modules).

Should I just update the new modules path in the httpd.conf file and
restart httpd?

Please let me know if it is correct. Are there any additional steps
required?

Difference in Apache version

Hello all,

- I am running Apache httpd version *2.2.29* and server built on Aug 23
2015 13:19:54 .

/usr/local/apache2/bin/httpd -v

*Server version: Apache/2.2.29 (Unix)*

*Server built: Aug 23 2015 13:19:54*

- But the server-status page shows a different version and built.

[image: Inline image 1]

- Can you please advise what is wrong with my configuration?

Apache server-status and balancer-manager

Team,

I have installed Apache 2.2.29 version on RHEL VM, but the "Server Version"
on *server-status*and *balancer-manager* is showing as Apache/2.2.15.

I am confused why its different. Am i missing any configuration?