DevHeads.net

Postings by Amey Abhyankar

Unable to install 'Dbeaver' in Ubuntu 16.04

Hello,

I am trying to install 'Dbeaver' in Ubuntu 16.04 but getting following error =

daemon.json file not found in /etc/docker dir in Ubuntu 16.04.5

Hello,

I am running Ubuntu 16.04.5
Have installed 'Docker version 17.12.0-ce, build c97c6d6'

I want to modify couple of path's in daemon.json but I am unable to
locate daemon.json file under /etc/docker.
Also, I am unable to locate this file anywhere if I do 'locate *.json'

After searching I found 1 or 2 discussion where it is suggested to
create daemon.json file in /etc/docker but what should the contents in
it? And will that impact currently running docker service?

Regards,
Amey.

Apache 2.4 in Ubuntu 16.04 not parsing php 5.6 files

Hello,

I have installed Apache 2.4 & php 5.6 on my Ubuntu 16.04 laptop.
I installed php & apache using apt-get command.
I copied sample php file in /var/www/html dir

My sample php code as follows =

Apache is working fine.
If I hit <a href="http://localhost/test.php" title="http://localhost/test.php">http://localhost/test.php</a> it just shows the code as above.
Apache fails to parse the sample file.

I did lot of R&D by Googling possible solutions & ensured php5.6
module is enabled.

Any help? Thanks.

Regards,
Amey.

wxWidgets error while compiling pgadmin3-1.22.0 in Ubuntu 16.04 LTS

Hello,

I am trying to run ./configure to install pgadmin3-1.22.0 from source
downloaded from pgadmin's git page.

Due to ssh key issue in pgadmin3-1.22.2, I need lower version which works.

Can somebody suggest how to get wxWidgets for Ubuntu 16.04 LTS? Thanks.

Error = configure: error: Could not find your wxWidgets installation.
You might need to use the --with-wx=DIR configure option

Regards,
Amey.

Facing issue with php 5.5.x in Ubuntu 14.04.5 LTS

Hello,

I am getting php related errors in my product running on 14.04.5 LTS.
Details as follows =

Error =

[Mon Mar 301708 2018] [:error] [pid 19149] [client <ip_address>:45627]
PHP Fatal error: Call to a member function getLanguage() on a
non-object in /opt/user/<code_path>/webroot/inc/include.php on line
198

line 198 = define("sLANG", $_SESSION['obj_ClientConfig']->getLanguage() );

php version = PHP 5.5.9-1ubuntu4.23 (cli) (built: Feb 8 2018 21:59:47)
OS = Ubuntu 14.04.5 LTS [64bit]
uname = 3.13.0-133-generic #182-Ubuntu SMP Tue Sep 19 15:49:21 UTC
2017 x86_64 x86_64 x86_64 GNU/Linux