DevHeads.net

Postings by Chris

New member on the block; Introducing Apprise

Hi everyone,

This is my third post in this forum, but this time it's to thank you all
for your earlier support. But more importantly, and according to the
Fedora wiki, it's advisable to introduce ourselves (especially when
attempting to submit a new package for review). Well.. here I go :)

My name is Chris, and I've actually been contributing to the RPM community
for years, but in a bit of an indirect way. For years I run/ran
<a href="http://nuxref.com/nuxref-repository/" title="http://nuxref.com/nuxref-repository/">http://nuxref.com/nuxref-repository/</a> (similar to nux, or rpmforge, etc) but
on a much smaller scale. I mostly focused on EPEL 6 and 7 stuff.

python-flake8 package not available in F30

I have a slightly different packaging issue with the repository structure
(similar state on both COPR an Koji).

In epel7, f28, and f29 i can use the line:
BuildRequires: python-flake8

However this package is not available on f30 servers:
Koji ref: <a href="https://koji.fedoraproject.org/koji/taskinfo?taskID=33329251" title="https://koji.fedoraproject.org/koji/taskinfo?taskID=33329251">https://koji.fedoraproject.org/koji/taskinfo?taskID=33329251</a>

I realize f30 is in rawhide state right now, so i wasn't sure if this is
the right forum for this question or if i should just wait?

Chris

Koji Build Failure Due To Dependency EPEL Dependency Issue

The error:

DEBUG util.py:490: BUILDSTDERR: Error:
DEBUG util.py:490: BUILDSTDERR: Problem: conflicting requests
DEBUG util.py:490: BUILDSTDERR: - nothing provides python2-oauthlib
needed by python2-requests-oauthlib-0.8.0-5.el7.noarch
DEBUG util.py:634: Child return code was: 1

This same package builds fine using copr (done so here):
<a href="https://copr.fedorainfracloud.org/coprs/lead2gold/apprise/" title="https://copr.fedorainfracloud.org/coprs/lead2gold/apprise/">https://copr.fedorainfracloud.org/coprs/lead2gold/apprise/</a>

The spec file entry (that works fine for epel7 on Copr) is:
BuildRequires: python2-requests-oauthlib
BuildRequires: python2-oauthlib

This entry just produces an error that all requirements could