DevHeads.net

After send status 200 response, process exited

Hi,,
I started my apache successfully, but when I am sending request from
browser. Getting ERR_NO_RESPONSE in chrome.

I added LogLevel trace7 and collected the error log. What I have found
that, after successful response of requests(status-200), process is
exited. I thought its coredump therefore added directory for coredump also
but didn't get anything error .

What is the possible cause of this ?

Response sent with status 200, headers:
[Fri Dec 08 10:01:51.381659 2017] [http:trace5] [pid 1140850845]
\apache\httpd-2.4.25\modules\http\http_filters.c(1096): [client
15.213.82.149:59662] Date: Fri, 08 Dec 2017 10:01:51 GMT
[Fri Dec 08 10:01:51.381666 2017] [http:trace5] [pid 1140850845]
\apache\httpd-2.4.25\modules\http\http_filters.c(1099): [client
15.213.82.149:59662] Server: Apache/2.4.25 (Unix)
[Fri Dec 08 10:01:51.381675 2017] [http:trace4] [pid 1140850845]
\apache\httpd-2.4.25\modules\http\http_filters.c(918): [client
15.213.82.149:59662] Content-Length: 2810
[Fri Dec 08 10:01:51.381683 2017] [http:trace4] [pid 1140850845]
\apache\httpd-2.4.25\modules\http\http_filters.c(918): [client
15.213.82.149:59662] Keep-Alive: timeout=5, max=100
[Fri Dec 08 10:01:51.381690 2017] [http:trace4] [pid 1140850845]
\apache\httpd-2.4.25\modules\http\http_filters.c(918): [client
15.213.82.149:59662] Connection: Keep-Alive
[Fri Dec 08 10:01:51.381697 2017] [http:trace4] [pid 1140850845]
\apache\httpd-2.4.25\modules\http\http_filters.c(918): [client
15.213.82.149:59662] Content-Type: text/html; charset=ISO-8859-1
[Fri Dec 08 10:01:52.312222 2017] [core:trace4] [pid 1845493770]
\apache\httpd-2.4.25\server\mpm_common.c(533): mpm child 50331671 (gen
1/slot 2) started
[Fri Dec 08 10:01:58.324625 2017] [core:notice] [pid 1845493770] AH00052:
child pid 1140850845 exit signal signal #31 (31)

After serving the request, process is exited with signal 31.

Thanks
Hemant

Comments

Re: After send status 200 response, process exited

By Eric Covener at 12/08/2017 - 08:07

you might need to add that signal to ap_fatal_signal_setup() otherwise
Apache will not change to CoreDumpDirectory before it dumps. Or, if
your OS supports it, tell it to put cores somewhere other thsan the
working directory.

On Fri, Dec 8, 2017 at 5:57 AM, Hemant Chaudhary
<hemantdude. ... at gmail dot com> wrote:

Re: After send status 200 response, process exited

By Hemant Chaudhary at 12/08/2017 - 08:38

Hi

Yes my OS supports coredump but there also no stack is created.

Re: After send status 200 response, process exited

By Eric Covener at 12/08/2017 - 08:49

On Fri, Dec 8, 2017 at 7:38 AM, Hemant Chaudhary
<hemantdude. ... at gmail dot com> wrote:
please read my prior response more carefully.