DevHeads.net

postfix 3.3.0 and vda quota patch

Hello,

it seems that "postfix vda" patch that brings quota support for virtual
maildirs is not updated / not mantained anymore. There is no patch for
3.3.0
<a href="http://vda.sourceforge.net/" title="http://vda.sourceforge.net/">http://vda.sourceforge.net/</a>

I used that patch to create a custom mailserver on ubuntu 10.04 and 14.04,
but 18.04 uses postfix 3.3.0 and i'm stuck.

Is there any way to achieve the same result (maildirsize quota and
overquota replay) without the vda patch at this point ?

Thank you,
Roberto S.

Comments

Re: postfix 3.3.0 and vda quota patch

By Christos Chatzaras at 05/16/2018 - 10:21

dovecot + quota plugin

Re: postfix 3.3.0 and vda quota patch

By dev rob0 at 05/16/2018 - 10:21

On Wed, May 16, 2018 at 02:30:52PM +0200, Roberto Sebastiano wrote:
Note that your patch never was supported on this list.

The recommended way is via a policy service which checks with the
imapd, and causes a rejection for overquota recipients. Dovecot
actually includes such a policy server. Refer to the Dovecot wiki
for use and setup instructions.