DevHeads.net

Postfix 3.3.1 - Warning: mysql: ...... unused parameter: user

I upgraded to Postfix 3.3.1 from 2.x.x two days ago. I keep seeing the
following warnings:

This is repeated for the other files: domains.cf and forwardings.cf

I don't see any warnings for the file: alias-maps.cf even though it is
similiar to the above files.

I looked in the documentation (man pages and HTML readme files) and can't
find the answer. I have been using this setup since 2009 without a problem.
Is there a new database paradigm (connection style/template/method) that we
should switch too?

The documentation has not changed. It still lists using the above parameters
in the MYSQL_README.html file.

I saw that there were new directories added to /etc/postfix called
dynamicmaps.cf.d and postfix-files.d with a filed called mysql in each
directory. This leads me to believe that there is a new connection method.

Please do not ask me to post my config files.

Comments

Re: Postfix 3.3.1 - Warning: mysql: ...... unused parameter: use

By volunteer at 08/17/2018 - 12:05

I used the raw tags and I can't see the error messages now. The error
messages were:
<br /><br />
Aug 12 22:39:28 crash postfix[21125]: /usr/sbin/postconf: warning:
mysql:/etc/postfix/users.cf: unused parameter: password=xxxxxxx
Aug 12 22:39:28 crash postfix[21125]: /usr/sbin/postconf: warning:
mysql:/etc/postfix/users.cf: unused parameter: dbname=mailbox
Aug 12 22:39:28 crash postfix[21125]: /usr/sbin/postconf: warning:
mysql:/etc/postfix/users.cf: unused parameter: query=SELECT mail FROM users
WHERE mail='%>
Aug 12 22:39:28 crash postfix[21125]: /usr/sbin/postconf: warning:
mysql:/etc/postfix/users.cf: unused parameter: user=administrator
Aug 12 22:39:28 crash postfix[21125]: /usr/sbin/postconf: warning:
mysql:/etc/postfix/users.cf: unused parameter: hosts=127.0.0.1
<br /><br />

Re: Postfix 3.3.1 - Warning: mysql: ...... unused parameter: use

By Viktor Dukhovni at 08/17/2018 - 12:28

Perhaps you built Postfix from source on a system that does not
have the "m4" preprocessor installed. If so, install m4, and
rebuild.